内容标题18

  • <tr id='QwGSMK'><strong id='QwGSMK'></strong><small id='QwGSMK'></small><button id='QwGSMK'></button><li id='QwGSMK'><noscript id='QwGSMK'><big id='QwGSMK'></big><dt id='QwGSMK'></dt></noscript></li></tr><ol id='QwGSMK'><option id='QwGSMK'><table id='QwGSMK'><blockquote id='QwGSMK'><tbody id='QwGSMK'></tbody></blockquote></table></option></ol><u id='QwGSMK'></u><kbd id='QwGSMK'><kbd id='QwGSMK'></kbd></kbd>

    <code id='QwGSMK'><strong id='QwGSMK'></strong></code>

    <fieldset id='QwGSMK'></fieldset>
          <span id='QwGSMK'></span>

              <ins id='QwGSMK'></ins>
              <acronym id='QwGSMK'><em id='QwGSMK'></em><td id='QwGSMK'><div id='QwGSMK'></div></td></acronym><address id='QwGSMK'><big id='QwGSMK'><big id='QwGSMK'></big><legend id='QwGSMK'></legend></big></address>

              <i id='QwGSMK'><div id='QwGSMK'><ins id='QwGSMK'></ins></div></i>
              <i id='QwGSMK'></i>
            1. <dl id='QwGSMK'></dl>
              1. <blockquote id='QwGSMK'><q id='QwGSMK'><noscript id='QwGSMK'></noscript><dt id='QwGSMK'></dt></q></blockquote><noframes id='QwGSMK'><i id='QwGSMK'></i>

                浅谈二开插件问题点

                1. 标准的执行计划任务都是可以正常执行,二开的执行计划计划不能正常执行,提示Class is not Exist,但手动可以执行成功,



                ? ? ?最终发现是如下两点造成,

                ? ?1)客户使用的VS 2015,默认用的是.net 4.5版本

                ? ?2)拿到客户组件后在LSpy中对比发@现缺少了几个核心组件,其中有个kingdee.BOS组件是低版本的不一致。



                2.部署二开插件后@ ,全员客户端出现频繁闪退,抓取了dumps

                ,临时将二开插件在website/bin目录下移除后恢复正常,也是拿到客户的二开组件后,在VS 2019中打开测试发现,开发人员用的是.net 4.7.2

                在VS中选择.NET Framework4.0重新注册后,放到website/bin目录下重启IIS后正常。


                综上所述,我们在平时开发过程中一定要注意,不然会影响生产环境,细节决定成败。

                1. .Cloud是基于开发NET Framework4.0版本开发的,

                2. 引用组件版本必须和本地金蝶云星空版本一致。

                admin
                admin管理员

                上一篇:简单二开插件创建
                下一篇:改了服务器名,修改了配置文件后管理中心可以登录,业务站点50 …

                留言评论

                暂无留言
                取消
                扫码支持